Subject: nat, pppoe trouble
To: None <>
From: Joe Reed <>
List: current-users
Date: 09/29/2002 22:52:50

i'm having this really wierd problem, does anyone have any ideas on 

i've got a dsl connection coming into a friend's appartment, and i'm using  
NetBSD-current 1.5ZC (i386) on a pentiumII 400 i had laying around as a 
pppoe->ethernet router.  i've got ipnat and ipf set up to block all incoming 
traffic, and to allow all outgoing traffic.  i use dhcpd to give dynamic 
leases to the client computers.  the outgoing ethernet card plugs into a 
10baseT hub.  there are 3 client computers running off the hub 2 of them 
running windoze 2k, the other windoze 98.

the whole setup was running smoothly.

about a week ago, one of the windoze2k and the windoze 98 machine lost the 
ability to connect to download web pages, pop traffic, ftp traffic, etc.  
internet explorer/mozilla/mail clients would resolve the hostname, and the 
timeout.  however aol im worked fine.  also and 
continue to load fine.  all other url's time out.

the interesting thing is, the 3rd computer remains connected and working 

i have taken the following steps to attempt to determine the cause of the 
problem  (in the order i remember them, not necessarily in chronological 
1) rebooted all machines (even the NetBSD gateway)
2) swapped network cards between the working and non-working win2k machine
3) flushed and cleared ipf and ipnat rules
4) reinstalled windoze 2k on the machine that would not connect
5) moved ethernet cards to different pci ports (both on the NetBSD gateway and 
client computers)
6) swapped cat5 cables
7) replaced the hub with a switch
8) replaced the gateway's 2 linksys cards (tlp?) with new netgear cards (sip?)
9) swapped the hub ports into which the working and non-working computer's 
cat5 were plugged

however, throughout all of this, the same 2 computers remain only partially 
able to connect to the internet and the same one remains functioning 

i found it interesting that the ethernet card that worked in one machine 
(win2k) would not work in the other(also win2k).  even moving wires and hub 
ports did nothing.

i'm confused.  i'm thinking about wiping the machine and starting with 
something really current off of to see if a newer version 
will fix something.  but that seems very windoze-ish.  does anyone have any 
other ideas as to the cause or a solution to this problem?