Subject: Re: Update to i386: "ex0: uplistptr was 0"
To: Peter Seebach <>
From: Arto Selonen <>
List: current-users
Date: 09/26/2002 10:54:52

On Tue, 24 Sep 2002, Peter Seebach wrote:

> So, my i386 system just got upgraded from a July 16th kernel to a September
> 23rd kernel.
> Since the update, the network has wedged a couple of times; in each case,
> hitting a key on the console caused it to print:
> 	ex0: uplistptr was 0
> and then recover.

Hate to say this, but "me too!". Sources were retrieved from around 9am EEST on 23rd. Since I'm not the only one
seeing this I doubt my HW is giving up on me. Maybe related to 3C905B?

ex0 at pci0 dev 17 function 0: 3Com 3c905B-TX 10/100 Ethernet (rev. 0x30)
ex1 at pci0 dev 19 function 0: 3Com 3c905B-TX 10/100 Ethernet (rev. 0x30)

and I'm getting this every time it hangs:

ex1: uplistptr was 0
ex0: uplistptr was 0

So far, this has happened three times this week. I have two other i386
machines running on (almost?) the same sources, but so far they have
not experienced any problems (they have 3C905Cs + relatively quiet
network compared to the problem case).

I'd be glad to provide more information regarding this issue, if that
helps in fixing it. (If it is a known ex(4) issue, I would also like to
hear about it so I'd know changing the NICs would fix it).

Arto Selonen
#######======------  --------========########
Everstinkuja 5 B 35                               Don't mind doing it.
FIN-02600 Espoo         Don't mind not doing it.
Finland              tel +358 50 560 4826     Don't know anything about it.