Subject: Re: HEADS UP (Re: 1.5.x openssl problems)
To: Frederick Bruckman <>
From: Martti Kuparinen <>
List: current-users
Date: 08/30/2002 16:17:50
On Fri, 30 Aug 2002, Frederick Bruckman wrote:

> Best to figure out which intermediate library actually holds the
> shared library dependency on -lssl.1 and lcrypt.0, to rebuild it
> first.

Of course I tried that, I even ran "make configure", suspended it with ^Z
just after it had created the buildlink stuff and removed all references
to the old openssl libs. I rebuilt both cyrus-sasl and cyrus-imapd
in this funny way. Result: references to the old libs.

The only way which worked for me was to be remove /usr/lib/libssl.0*
and libcrypt.0*. Not very elegant I must say :-(

This is more a pkgsrc issue I guess, it shouldn't try to use libs
outside work/.buildlink...


Martti Kuparinen <>      NetBSD - No media hype