Subject: Re: problems booting really small machines to multi-user mode
To: NetBSD-current Discussion List <>
From: Greywolf <>
List: current-users
Date: 08/26/2002 16:00:32
On Mon, 26 Aug 2002, Greg A. Woods wrote:

# > Wow. Mine (486 @ 66, 4 MB RAM, 1.5 ZC) takes about 3-4 minutes. I have the feeling
# > you should investigate what's really going on there
# I probably should....
# I should also not that I have not yet tried that "fast & loose" option...

I should note that fast&loose breaks if any of the startup scripts explicitly
call "exit" for any reason.

# > (although I bet that
# > it's a royal PITA to do so when it currently takes an hour to boot up :-)
# It is....  :-)
# but normally when I use that machine I just run dhclient from single
# user mode, then 'ssh'....  :-)
# I wanted to try taking it to multi-user mode the default way so that I
# could see how well it worked and then if it worked "OK" I would do that
# whenever expected I wanted multiple virtual terminals.
# As is I muddle through manually firing up virtual terminals and then
# just manually start shells on them.....

An hour to boot.

That seems...unwieldy and unlikely (not in that "I don't believe you" but
more of "Your machine is probably doing something, somewhere, it oughtn't").

But again, this is kind of OT.  Wups, no, someone changed the T :).

But since we're here, I have an interesting note:

/etc/rc will only ever source /etc/rc.conf once.
/etc/rc.shutdown will source it for every script run.

I should really try to fix this...

NetBSD: Agnostics in the Platform Religious Wars.