Subject: Re: pciide lossage on current-macppc
To: Manuel Bouyer <>
From: Monroe Williams <>
List: current-users
Date: 08/23/2002 11:17:11
on 8/23/02 3:25 AM, Manuel Bouyer at wrote:

> On Fri, Aug 23, 2002 at 02:30:43AM -0700, Monroe Williams wrote:
>> I sent this to current-users 3 months ago, and I haven't seen any response.
>> I still see the problem with a kernel built from cvs today.  Is it just my
>> hardware, or is this really broken?
> There can be several causes:
> a) the adapter has a bug with interrupts handling
> b) the driver has a bug
> c) the hardware (drives, cables) don't play nice together
> As far as I can tell the interrupt routine in the driver is OK, but I don't
> have programming docs for this adapter. c) can be caused by interferences
> between the 2 cables, or by interferences on the power supply lines if
> the PS isn't good enouth.

Hmmm.  I've tried another controller (Promise ATA/133) and it seems to have
the same problem.  If I use both cards and split the drives so that one is
on each card, the problem goes away.

I've also tried swapping out one of the drives for a different model.  (The
other drive has my /usr partition on it, so I kind of have to keep it.)
I'll try some different cables and alternate setups this weekend.

Is anyone out there using a similar setup?  The machine is a Power Mac 7500
with a G3 upgrade card.

-- monroe
Monroe Williams