Subject: Re: UltraDMA problems under 1.6F (probably hardware)
To: gabriel rosenkoetter <>
From: Richard Earnshaw <>
List: current-users
Date: 08/22/2002 16:08:33
> On Thu, Aug 22, 2002 at 10:20:32AM +0100, Richard Earnshaw wrote:
> > So I'm still stuck with a UDMA-5 disk and a UDMA-2 controller that can't 
> > agree on running above UDMA-1.
> You get DMA at all? I degrade all the way to PIO 4 and nothing else
> (which I understood to be effectively DMA 0 and UDMA 0). Does your
> M5229 attach, as mine does, as a pciide (as opposed to a wdc)?

Yes, I get UDMA-1.  And yes, it does mount as pciide0 -- note that wdc.c 
in dev/ic is part of the wdc_base fileset -- pciide is the materialization 
of that code on a pci subsystem.

> We're using the same chipset (ALi M5229), which should support
> UDMA-6 (though NetBSD doesn't) and I'm using a drive which should
> be able to do the same (though, again, NetBSD can only do UDMA-5)...
> and I end up with no DMA at all.

Although both are reporting as M5229 this is a family of chips with 
different capabilities -- apparently the revision code tells which 
capabilites are available (see acer_chip_map).

> I've (unsuccessfully) tried various tinkering in
> src/sys/dev/pci/pciide.c and .../pciide_acer_reg.h, mostly backing
> out changes that were made recently. But it occured to me that I've
> got no reason to believe that this chipset *ever* worked, since I've
> only ever seen it not work.
> Did it, at some point, behave for you, Richard?
No, I've never had this disk running above UDMA-1 since I bought it.  I 
can't remember whether the previous disk in the machine worked at that 
speed, and I no-longer have the disk.

> Btw, ought we be having this conversation on tech-kern rather than
> current-users? (My fault, really; I'd orginally figured this was
> some braindead thing I'd done wrong, but if it's going to involve
> fixing the Acer driver...)