Subject: Re: UltraDMA problems under 1.6F (probably hardware)
To: None <>
From: gabriel rosenkoetter <>
List: current-users
Date: 08/22/2002 10:03:58
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Thu, Aug 22, 2002 at 10:20:32AM +0100, Richard Earnshaw wrote:
> So I'm still stuck with a UDMA-5 disk and a UDMA-2 controller that can't=
> agree on running above UDMA-1.

You get DMA at all? I degrade all the way to PIO 4 and nothing else
(which I understood to be effectively DMA 0 and UDMA 0). Does your
M5229 attach, as mine does, as a pciide (as opposed to a wdc)?

We're using the same chipset (ALi M5229), which should support
UDMA-6 (though NetBSD doesn't) and I'm using a drive which should
be able to do the same (though, again, NetBSD can only do UDMA-5)...
and I end up with no DMA at all.

I've (unsuccessfully) tried various tinkering in
src/sys/dev/pci/pciide.c and .../pciide_acer_reg.h, mostly backing
out changes that were made recently. But it occured to me that I've
got no reason to believe that this chipset *ever* worked, since I've
only ever seen it not work.

Did it, at some point, behave for you, Richard?

Btw, ought we be having this conversation on tech-kern rather than
current-users? (My fault, really; I'd orginally figured this was
some braindead thing I'd done wrong, but if it's going to involve
fixing the Acer driver...)

gabriel rosenkoetter

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.0.7 (NetBSD)