Subject: Re: Does PPP MS-CHAP and MPPE??? Which version of NetBSD?
To: Gerald C. Simmons <>
From: cube <>
List: current-users
Date: 07/16/2002 20:00:26
Le Tue, 16 Jul 2002 08:31:00 -0700 (PDT)
Gerald C. Simmons a écrit :
> I'm trying to get PPTP working via PoPToP to connect from a Windows VPN
> Client.

It works. I've tested it with 1.5/i386 and Windows {98,ME,XP}. So it works
with both 40 and 128 bits encryption.

> Evidently, PPP needs to have MS-CHAP and MPPE for Authentication. The
> Linux camp has patches for PPP to add this support.
> Anyone know the story with US??

Making it work is pretty straightforward, once you know what you need.

When you install PoPToP via pkgsrc, define POPTOP_USE_MPPE. This will
install ppp-mppe-2.3.9, which contains ppp-2.3.9 and a kernel module
handling mppe.

Then what you need is to enable LKM in the kernel (which is by default, at
least on i386), get mppe.o loaded into the kernel at start-up, take care
of any interaction between ppp-2.4 (the one installed with the system) and
ppp-2.3.9, and configure PoPToP to use ppp-2.3.9.

I may still have some configuration files if you want, although I doubt I
have currently a working installation of this.


That's how I did it, Anton. I never saved anything
for the swim back.
Vincent/Jerome, in Gattaca.