Subject: problems with USB floppy
To: None <>
From: Steve Bellovin <>
List: current-users
Date: 07/11/2002 21:43:52
I reported this problem long ago, but I figured I'd try it again on 
1.6beta3.  No joy.

The problem is with a USB floppy drive:

umass0 at uhub1 port 2 configuration 1 interface 0
umass0: TEAC TEAC FD-05PUB, rev 1.00/0.00, addr 2
umass0: using UFI over CBI
atapibus1 at umass0 channel 0: 2 targets
sd0 at atapibus1 drive 0: <TEAC, FD-05PUB, 1026> type 0 direct removable
sd0: drive offline

(The machine itself is a i386.)  I can read from it just fine, but when 
I try to write I get:

sd0(umass0:0:0):  Check Condition on CDB: 0x2a 00 00 00 00 13 00 00 01 00
    SENSE KEY:  Not Ready
     ASC/ASCQ:  ASC 0x04 ASCQ 0xff

I read from it by mounting it (-r -t msdos /dev/sd0e); it just worked.  
I unmounted it -- didn't touch the disk itself, so there's no reason 
for it to have gone not ready -- and did the same mount without -r, and 
tried to copy a file.  No joy.

		--Steve Bellovin, (me) ("Firewalls" book)