Subject: 1.6_BETA3/amiga 200206260000 crashed
To: None <>
From: Klaus Heinz <>
List: current-users
Date: 06/29/2002 17:59:42

while compiling X on a fresh install of 1.6_BETA3 (200206260000) I
suddenly could not use /bin/ls anymore. Any use of 'ls' or '/bin/ls'
by me or as 'root' produced the usage message

  $ ls
  usage: ls [-1ACFLRSTWacdfgiklmnopqrstux] [file ...]

Other commands worked fine, so I could use /altroot/bin/ls (after
'ldconfig /altroot/usr/lib' in order to use the 1.5.2 a.out binaries in

I stopped the compiler run, stopped the 'window' command that was
running at this time and found myself in ddb. 'trace' showed this:

  cpu_Debugger(8, e, 851000, c6f46, 7285c80) +6
  panic(2495ea, 851000, 7285cd8, 1dd47e, 8) +9e
  panictrap(8, 851000, 73a6ae00, 7285d2c) +5e
  trapmmufault(8, 851000, 73a6ae00, 7285d2c, 7248cb4) +2bc
  trap(8, 851000, 73a6ae00) +30e
  pmap_enter_ptpage(595940, 1c000) +37a
  pmap_enter(595940, 1c000, cc5c000, 5, 20) +84
  uvm_fault(70beed8, 22000, 0, 1) +5cc
  trapmmufault(88, 1429000, 23ea2, 7285fac, 7248cb4) +144
  trap(8, 1429000, 23ea2) +30e
  faultstkadj() + 0

Trying to produce a dump failed. Although it said 'dumping to dev ...
succeeded' the machine did not reboot but stuck again with

  uvm_fault(0x27c4c8, 0x0, 0, 0x1) -> 0xe
    type 8, code[mmu, ssw] 1468200
  panic mmu fault
    stopped in pid 276 (bash) at cpu_Debugger +0x6    unlk a6

After resetting the machine, 'savecore' could not find any crash dump.


NetBSD 1.6_BETA3 (GENERIC) #0: Wed Jun 26 17:53:43 UTC 2002
Amiga 3000 (68060 rev.1 CPU/MMU/FPU)
total memory = 81920 KB
avail memory = 73440 KB
using 524 buffers containing 4192 KB of memory
memory segment 0 at 08000000 size 05000000
memory segment 1 at 07000000 size 01000000
memory segment 2 at 00000000 size 00200000
mainbus0 (root)
clock0 at mainbus0: CIA B system hz 100 hardware hz 709379
Calibrating delay loop... 21/1024 us
a34kbbc0 at mainbus0
ser0 at mainbus0: input fifo 512 output fifo 32
par0 at mainbus0
kbd0 at mainbus0: CIA A type Amiga
ms0 at mainbus0
grfcc0 at mainbus0
grf0 at grfcc0: width 640 height 400 colors 4
ite0 at grf0: rows 0 cols 0 repeat at (30/100)s next at (10/100)s has keyboard
fdc0 at mainbus0: dmabuf pa 0x1e3694: dmabuf ka 0x8d9d694
fd0 at fdc0 unit 0: 3.5dd 80 cyl, 2 head, 11 sec [9 sec], 512 bytes/sec
fd1 at fdc0 unit 2: 3.5dd 80 cyl, 2 head, 11 sec [9 sec], 512 bytes/sec
ahsc0 at mainbus0
scsibus0 at ahsc0: 8 targets, 8 luns per target
aucc0 at mainbus0
audio0 at aucc0: half duplex
zbus0 at mainbus0: i/o size 0x04000000
cbiisc at zbus0: pa 0xea0000 man/pro 8512/25 not configured
le0 at zbus0 pa 0xe90000 man/pro 514/112: address 00:80:10:00:08:b3
le0: 16 receive buffers, 4 transmit buffers
grfcv0 at zbus0 pa 0x40000000 man/pro 8512/34
grf5 at grfcv0: width 640 height 480 colors 16
ite5 at grf5: rows 60 cols 80 repeat at (30/100)s next at (10/100)s has keyboard
grfcv: CyberVision64 with 4MB being used
scsibus0: waiting 2 seconds for devices to settle...
ahsc0: target 2 now synchronous, period=208ns, offset=12.
sd0 at scsibus0 target 2 lun 0: <IBM, DORS-32160, S82C> SCSI2 0/direct fixed
sd0: 2063 MB, 6703 cyl, 5 head, 126 sec, 512 bytes/sect x 4226725 sectors
ahsc0: target 3 now synchronous, period=208ns, offset=12.
sd1 at scsibus0 target 3 lun 0: <Maxtor 3, 2049H2, YAC6> SCSI2 0/direct fixed
sd1: 19541 MB, 19541 cyl, 16 head, 128 sec, 512 bytes/sect x 40021632 sectors
ahsc0: target 5 now synchronous, period=208ns, offset=12.
sd2 at scsibus0 target 5 lun 0: <SEAGATE, ST51080N, 0958> SCSI2 0/direct fixed
sd2: 1030 MB, 4826 cyl, 4 head, 109 sec, 512 bytes/sect x 2109840 sectors
4 views configured
Kernelized RAIDframe activated
root on sd2a dumps on sd2b
root file system type: ffs