Subject: Completely strange
To: None <>
From: Mark White <>
List: current-users
Date: 06/24/2002 14:20:11
I'm seeing some very odd networking behaviour under current.
Basically, network transfer rates from one particular
machine to another are pathetically low.  (No problems in
the other direction).  Data rates of a few kB per second are
usual; it regularly stalls altogether.  Doesn't matter what
protocol, or which end initiates the connection.  I've had
no network trouble with either machine in any other context.

The two machines in question are a NetBSD 1.5Zx 2xP3 with an
ex network interface, and an iBook running OSX.  Things that
solve the problem:

    - Replacing *either* machine with *any* other.  The
      problem only occurs between these two particular
    - Rebooting the NetBSD box to kernel 1.5.2
    - Certain network configurations. It generally behaves
      better when there are no routers between the two
      machines, but that's not always true.

Things that haven't yet solved the problem:

    - Updating to 1.5ZC of 2002-05-18 (last sync date for
      sommerfeld_i386_mp1, I think)
    - Rebuilding the kernel with sundry different options
      (including disabling MP, and trying a stock GENERIC
      binary from the snapshot)
    - Looking at tcpdump very carefully.  Looks like packets
      are just not getting sent from the NetBSD machine as
      often as they should.  No nasty delays in ICMP
      packet transit time, or anything.

Does anyone have a clue what this could be?  I've been
chasing it round in clircles for a while.  I don't think
it's a routing problem; could be a mis-configured switch or
dodgy cable, but it's kind of odd it only effects a
particular pair of machines, and is solved in 1.5.1, if so...

Mark <><