Subject: Re: Linux emulation under -current
To: Murray Armfield <>
From: Jim Bernard <>
List: current-users
Date: 06/11/2002 07:42:49
On Tue, Jun 11, 2002 at 03:14:08PM +1000, Murray Armfield wrote:
> Hi Folks,
> 	I'm trying to get some of my linux apps going, which haven't worked since 
> going to 2.4.18 emulation and 7.3 suse pkgsrc on my i386 current machine 
> (20020610).
> 	In particular I'm trying forte4java community edition from Sun, and limewire 
> a filesharing app. Both of them start and then just hang. Killable 'thou. If 
> I look at systat -w 1 vmstat, I can see most time has gone from user to 
> system and there are a very large number of traps and page faults going on 
> until app is killed. Seems like some kind of loop.
> 	Has anyone else seen this type of thing? Any known probs on linux emulation 
> on i386?

  This sounds similar to problems reported in PR's 16342 and 16349.  Tron has
suggested disabling linux_sys_getdents64 as a temporary workaround (see the
PR's), and it worked for me.  If it's the same problem, downgrading SUSE to
6.4 also works.