Subject: -current vs a Dell Latitude c840
To: None <>
From: Paul Dokas <>
List: current-users
Date: 06/04/2002 14:48:30
I just received a Dell Latitude c840 laptop yesterday, and I'm struggling
to shoehorn NetBSD onto it.  Using both the 20020518-1.5ZC snapshot and
NetBSD-1.6_BETA1, I can install just fine.  The floppy boots, sysinst
works great and I get NetBSD onto the drive without any problems.

However, when I boot off of the harddrive, the kernel loads and starts
probing the hardware and then hangs.  I have to power cycle the machine
to get it back.  This happens with the GENERIC and GENERIC_LAPTOP kernels.

The place where it hangs is where I would expect it to start probing
the PCMCIA subsystem.  Basically, the last thing that I see is this:

  audio0 at auich0: full duplex, mmap, independent
  Intel 82801CA/CAM Modem (modem communications, revision 0x02) at pci0 dev 31 function 6 not configured
  isa0 at pcib0
  com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
  pckbc0 at isa0 port 0x60-0x64
  pckbd0 at pckbc0 (kbd slot)
  pckbc0: using irq 1 for kbd slot
  wskbd0 at pckbd0: console keyboard, using wsdisplay0
  pms0 at pckbc0 (aux slot)
  pckbc0: using irq 12 for aux slot
  wsmouse0 at pms0 mux 0
  lpt0 at isa0 port 0x378-0x37b irq 7

I've also tried disabling various things through the BIOS.  And I've
tried removing as much of the hardware as I can.  Nothing helps.

I suspect that I'll need to build a custom kernel that avoids some broken
thing (PCMCIA and/or Cardbus perhaps?)  That's my next task.

But, I thought that I'd toss this problem out and see if anyone else
had seen it.

Paul Dokas                                  
Don Juan Matus:  "an enigma wrapped in mystery wrapped in a tortilla."