Subject: Re: HELP!! Intel i815 on -CURRENT(20020424-1.5ZC)
To: Steve Woodford <>
From: Olaf Seibert <>
List: current-users
Date: 04/28/2002 17:23:04
On Sun 28 Apr 2002 at 08:40:10 +0100, Steve Woodford wrote:
> On Sun, 28 Apr 2002, Thomas Asami wrote:
> > I downloaded i386 snapshot version(20020424-1.5ZC).
> > I'm using Intel i815, when I run ``startx'', I see nothing in
> > my screen, and I can't use ``Ctrl+Alt+backspace'' to quit X,
> > so I should restart the machine :-(

You can probably still switch to other virtual consoles, or telnet or
ssh into the machine.

> Please post the contents of /var/log/XFree86.0.log. That should show where
> things fall over.
> It actually sounds a bit like the problem I've just battled with on a
> laptop equipped with an i830 chipset. If so, I have a fix. :)

On advice from here and other places, I did the following:

1. Enable agp in the kernel:

    agp*    at pchb?

2. Make the device node and symlink for it in /dev:

    cd /dev; MAKEDEV agp0

3. for X, turn off int-10 use (not sure if that is really still needed
   actually, I'll try that later), in /etc/X11/XF86Config:

    Section "Device"
	Identifier  "Card0"
	Driver      "i810"
	VendorName  "Intel"
	BoardName   "i815"
	BusID       "PCI:0:2:0"
	Option	    "NoInt10"			<--

4. Make sure only the 1024x768 resolution of the laptop display is used:

    Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultDepth 24
	SubSection "Display"
	    Depth     24
	    Modes       "1024x768"		<--

> Cheers, Steve
___ Olaf 'Rhialto' Seibert - rhialto@polder    -- Ah only did well at school
\X/       -- tae git intae an O level class tae git away fae Begbie.