Subject: Re: FATAL: kernel too old
To: \"D'Arcy J.M. Cain\" <>
From: Thomas Klausner <>
List: current-users
Date: 04/17/2002 20:12:59
In article <> D'Arcy J.M. Cain wrote:
> I get this message when I try to build any Linux program from pkgsrc.
> Here is a sample of the actual output.
> /usr/pkg/emul/linux/sbin/ldconfig -r /usr/pkg/emul/linux
> FATAL: kernel too old
> *** Signal 6
> Stop.
> make: stopped in /usr/pkgsrc/emulators/suse_base
> *** Error code 1
> I couldn't find any reference to this on the mailing lists.  I am not even 
> sure which kernel they mean.  Is it the NetBSD or some sort of kernel 
> emulation interface?  I have tried removing everything and reinstalling but I 
> still get the same problem.  Does anyone know what is happening here.
> I am running a pretty current 1.5ZC kernel.

Most probably, you're one of the "lucky" few who have a 1.5ZC kernel
that doesn't yet have the Linux emulation fixes.
>From seeing 1.5ZC pkgsrc thinks you're running a fixed kernel, but
then ldconfig finds out you aren't.

Update your kernel, that should make the problem disappear.
Alternatively, you can install the suse64_* packages instead.


Thomas Klausner -
When all other means of communication fail, try words.