Subject: Machine hangs when accessing /dev/bktr
To: <>
From: Werner Backes <>
List: current-users
Date: 04/12/2002 00:40:32

sorry if this is not the right list for this question
but I couldn't find a better place to put it.
I have a Hauppauge WinTV card attached to my i386 box.
When I try to access /dev/bktr (e.g. via fxtv), the 
machine freezes at once without any message. I can also
force this by doing just "cat /dev/bktr". 
When I bought this card 2 weeks before, it worked fine 
using a generic kernel from one of the latest snapshots
(can't remember exactly). But then I changed the graphic
card and played around with different versions of XFree86.
Since that day, I cannot get the WinTV card to work again.
Of course I tried to replaced the new graphic card with
the old one and switched back to XFree86.3.3.6 which
worked before but no matter what I try: every time I
access /dev/bktr, the machine hangs. I also put the WinTV
card into another PCI slot so it gets another IRQ assigned,
but always the same: crash.
Now my question: what can I do further to track down the
problem? I tried everything I can think of and I'm running
out of ideas now :(.

dmesg output looks pretty good:

NetBSD 1.5ZA (GENERIC_DIAGNOSTIC) #0: Tue Feb 19 17:04:10 EST 2002
cpu0: Intel Pentium Pro (686-class), 199.45 MHz
cpu0: I-cache 8 KB 32b/line 4-way, D-cache 8 KB 32b/line 2-way
cpu0: L2 cache 256 KB 32b/line 4-way
cpu0: features fbff<PGE,MCA,CMOV>
total memory = 127 MB
avail memory = 112 MB
using 1659 buffers containing 6636 KB of memory
BIOS32 rev. 0 found at 0xf79c0
mainbus0 (root)
pci0 at mainbus0 bus 0: configuration mode 1
pci0: i/o space, memory space enabled
pchb0 at pci0 dev 0 function 0
pchb0: Intel 82441FX PCI and Memory Controller (PMC) (rev. 0x02)
pcib0 at pci0 dev 1 function 0
pcib0: Intel 82371SB PCI-to-ISA Bridge (PIIX3) (rev. 0x01)
pciide0 at pci0 dev 1 function 1: Intel 82371SB IDE Interface (PIIX3)
(rev. 0x00)
pciide0: bus-master DMA support present
pciide0: primary channel wired to compatibility mode
pciide0: disabling primary channel (no drives)
pciide0: secondary channel wired to compatibility mode
pciide0: disabling secondary channel (no drives)
pcn0 at pci0 dev 10 function 0: AMD PCnet-PCI Ethernet
pcn0: Am79c970A PCnet-PCI II rev 6, Ethernet address 00:80:29:66:05:03
pcn0: interrupting at irq 9
pcn0: 10base5, 10base5-FDX, 10baseT, 10baseT-FDX, auto, auto-FDX
bktr0 at pci0 dev 11 function 0
bktr0: interrupting at irq 10
bktr0: Hauppauge Model 44804 C148
bktr0: Warning - Unknown Hauppauge Tuner 0x30
bktr0: Hauppauge WinCast/TV, Philips NTSC tuner.
Brooktree product 0x0878 (miscellaneous multimedia, revision 0x11) at
pci0 dev 11 function 1 not configured
ahc1 at pci0 dev 12 function 0
ahc1: interrupting at irq 11
ahc1: aic7880 Wide Channel A, SCSI Id=7, 16/255 SCBs
scsibus0 at ahc1: 16 targets, 8 luns per target
isa0 at pcib0
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
pckbc0 at isa0 port 0x60-0x64
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
vga0 at isa0 port 0x3b0-0x3df iomem 0xa0000-0xbffff
wsdisplay0 at vga0 kbdmux 1: console (80x25, vt100 emulation), using
lpt0 at isa0 port 0x378-0x37b irq 7
pcppi0 at isa0 port 0x61
midi0 at pcppi0: PC speaker
sysbeep0 at pcppi0
isapnp0 at isa0 port 0x279: ISA Plug 'n Play device support
npx0 at isa0 port 0xf0-0xff: using exception 16
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
isapnp0: no ISA Plug 'n Play devices found
biomask ed65 netmask ef65 ttymask ffe7
scsibus0: waiting 2 seconds for devices to settle...
sd0 at scsibus0 target 0 lun 0: <CONNER, CFP2105S  2.14GB, 2D4D> SCSI2
0/direct fixed
sd0: 2048 MB, 3940 cyl, 10 head, 106 sec, 512 bytes/sect x 4194304
sd0: sync (100.0ns offset 15), 8-bit (10.000MB/s) transfers, tagged
Kernelized RAIDframe activated
boot device: sd0
root on sd0a dumps on sd0b
root file system type: ffs
wsdisplay0: screen 1 added (80x25, vt100 emulation)
wsdisplay0: screen 2 added (80x25, vt100 emulation)
wsdisplay0: screen 3 added (80x25, vt100 emulation)
wsdisplay0: screen 4 added (80x25, vt100 emulation)

Any hints?