Subject: Re: Help! Gphoto
To: D'Arcy J.M. Cain <>
From: Steven M. Bellovin <>
List: current-users
Date: 04/01/2002 21:44:54
In message <>, "D'Arcy J.M. Cain" writes:
>OK, here's the problem.  I am sitting in a motel room in Livermore, CA
>at the start of my first vacation in 12 years and I have set up my
>laptop to run gphoto under NetBSD 1.5ZC.  I just tried to upload some
>pictures to make room for more and gphoto doesn't work.  I tried to
>replace it with a compiled package from the NetBSD site and it needed
>an older version of so I symlinked  Didn't
>work.  I then built a package on my home system which is running the
>same version and it failed as well.  The error is "Illegal instruction"
>when I try to save the config file or access the camera after creating
>the proper config file by hand.
>So, I am looking for suggestions.  How do I get gphoto working?  Or is
>there something else that I can use for a Kodak 215 Zoom?  I know that
>there is a PCMCIA card that I can get that takes the small card and
>makes it look like a PCMCIA storage card.  Will that work on NetBSD?
>If all else fails maybe I can find some volunteers on the way that can
>simply download the pictures and FTP them to my home.  As I said I am
>in Livermore tonight and we will be travelling south for a while and then
>back to SF.
>If all else fails my final plan is to simply buy more cards to hold all
>the pics we want to take but that seems like a silly idea.  Besides, we
>were hoping to make the pics available as we travel.

I don't know what kind of card your camera has, but if it's a compact 
flash it will almost certainly just work.  I have

	/dev/wd1e       /cf     msdos   rw,noauto

in /etc/fstab on 1.5.x -- I mount it, and away I go.  (Well, that's 
what I used to use; at the moment, I'm using amd to accomlish the same 
thing.)  But the adapter costs about $10, and it's much faster than USB 
or serial uploads.

		--Steve Bellovin,
		Full text of "Firewalls" book now at