Subject: building kernels on -current
To: None <>
From: Steve Bellovin <>
List: current-users
Date: 02/21/2002 17:41:46
I suppose I let myself in for it...

I'd been happily running 1.5Y.  At some point, I must have done a cvs 
update on the kernel, which left me with a kernel that wouldn't build.  
I've seen lots of discussion of the "new tool chain" -- having also 
seen lots of comments to the effect that it's better to install a 
snapshot than to build the whole system from scratch, I downloaded the 
1.5ZA snapshot, installed it by hand (grumble -- via another download; 
I still don't grok the spell for installing from a previously-snarfed 
set of tarballs, and it was by hand since xbase.tgz didn't exist), did 
a 'cvs update' of the source, and tried again to build a kernel:

When I ran 'make depend', I got this:

/usr/src/tools/obj.i386/tools.NetBSD-1.5ZA-i386/bin/nbmkdep: not found

Suggestiosn gratefully appreciated.  (I've been building BSD kernels 
for (literally) decades -- I've never seen this one.)

		--Steve Bellovin,
		Full text of "Firewalls" book now at