Subject: Re: Damn it's difficult to get i810 to work :( was: [Re: i810 graphics and NetBSD -CURRENT...]
To: Manuel Bouyer <>
From: Johan Ihren <>
List: current-users
Date: 02/14/2002 20:53:10
Manuel Bouyer <> writes:

> > OK... Here's the whole story:
> > 
> > I installed NetBSD 1.5.3_ALPHA from scratch, excluding the XFree86 3.x that
> > shipped with NetBSD 1.5.3_ALPHA. Then, I followed Manuel's advice to get
> > XFree86 4.1.0 binary from the above URL. Done.
> > 
> > I have extract it, and try to run: # XFree86 -configure
> > Done... looks like the configure knows my i810 chip
> > 
> > But, after I tried: # XFree86 -xf86config /root/, it just
> > stalled!
> > Here's the last lines from /var/log/XFree86.log:
> > 
> > (==) VESA(0): DPI set to (75,75)
> > (||) VESA(0): Searching for matching VESA mode(s)
> > 
> > Then... it never went pass thru that :(
> > 
> > After that, I tried installing /usr/pkgsrc/sysutils/aperture, and... no
> > luck too.
> > 
> > Can somebody please help
> Well I can't I never tried XFree 4.

I have. 

We brought up a small everything-on-the-motherboard machine for
testing just the other day and as it turns out it had i810 graphics on
it. We did exactly the following to get it running:

1. Install and boot -current. Build and install a new kernel with the
   agp device present:

        agp*   at pchb?
2. Install XFree86 4.2.0. Run XFree86 -configure. This locked the
   machine solid. Reboot.

3. Remove the comment in front of "NoDDC" in the resulting XF86Config
   (yes, although the machine locks up, the config gets
   written). I.e. "NoDDC" should be ON.

4. Install the aperture driver from pkgsrc. Reboot.

Here we had the box up and running happily.

Now, if there only was support in NetBSD for the TI PCI4410
Cardbus+Firewire chip the box would move from "very nice" to

Now, I realise that John Indra is not running -current while we are
and that is basically my point. i810 *seems* to work more or less out
of the box with agp + aperture drivers in -current, so I'm not sure
that the blame for problems should be put on XFree86 4.2.0