Subject: Damn it's difficult to get i810 to work :( was: [Re: i810 graphics and NetBSD -CURRENT...]
To: None <>
From: John Indra <>
List: current-users
Date: 02/14/2002 10:07:29
First of all I wanna thank you for all the replies.

I am a newbie in NetBSD, but not so newbie in FreeBSD. Thus, I wanna start
quickly to have my NetBSD system up and running. For the ones that wish to
help, I really appreciate it.

> You need a specially-compiled X server, there is one at:
> In the same directory there is also the XF86Config I use.

OK. I am downloading it. But I really like to try first to get it running
with XFree86 4.1.0 (it's not impossible right?)

> Depending on your BIOS you may also need the aperture module:
> pkgsrc/sysutils/aperture
> Don't install the X shipped with NetBSD 1.5.x and get one from

OK... Here's the whole story:

I installed NetBSD 1.5.3_ALPHA from scratch, excluding the XFree86 3.x that
shipped with NetBSD 1.5.3_ALPHA. Then, I followed Manuel's advice to get
XFree86 4.1.0 binary from the above URL. Done.

I have extract it, and try to run: # XFree86 -configure
Done... looks like the configure knows my i810 chip

But, after I tried: # XFree86 -xf86config /root/, it just
Here's the last lines from /var/log/XFree86.log:

(==) VESA(0): DPI set to (75,75)
(||) VESA(0): Searching for matching VESA mode(s)

Then... it never went pass thru that :(

After that, I tried installing /usr/pkgsrc/sysutils/aperture, and... no
luck too.

Can somebody please help

Thank you very much