Subject: Lock up, suspect is moused
To: NetBSD Current-Users <>
From: Nate Johnston <>
List: current-users
Date: 02/13/2002 10:29:54

I use three mice on my system: a USB mini-trackball, a 3 button PS/2,
and the little joystick on my infrared keyboard.  The reciever for the
keyboard has a serial out for mouse events, so I use moused to intercept
the mouse.  So far, this setup has worked great, except that when I
left-click on the PS/2 mouse and moused is running, I get a double-click,
not a single-click (2 separate ButtonPress/ButtonRelease pair events).

The problem I just saw for the second time is this: I am using the mouse
through the serial interface, and X locks up: mouse frozen, unresponsive
to any events.  I logged on from a remote machine, and tried to kill X
(98% cpu usage) unsuccessfully.  I rebooted.

After the reboot when I logged back in I saw messages of this type over
and over again:

Feb 13 10:01:18 silentbob moused: No space left on device
Feb 13 10:01:18 silentbob moused: muxio inject event

I am calling moused as:

/usr/sbin/moused -3 -t microsoft -p /dev/tty03

Moused has been working fine for me for the past 2 weeks.  I'm at a loss
to explain what happened and I'd really like to fix whatever it was so
it wouldn't happen again.  Does anyone know what is going on?


Nate Johnston                 
GPG footprint: DEAF B505 0D84 1AEF A43F  91C5 71B3 D053 D0E1 3C05
"Nihil tam munitum quod non expugnari pecuna possit."  -Cicero