Subject: Re: i810 graphics and NetBSD -CURRENT...
To: None <,>
From: Manuel Bouyer <>
List: current-users
Date: 02/13/2002 10:46:35
On Wed, Feb 13, 2002 at 02:18:20PM +0700, John Indra wrote:
> Hi folks...
> Does the XFree86 shipped with NetBSD 1.5.3_ALPHA work with i810 based
> system?
> If not, how can I make it work?

You need a specially-compiled X server, there is one at:
In the same directory there is also the XF86Config I use.

Depending on your BIOS you may also need the aperture module:

> Oh yeah... How can I NOT install XFree86 3.x and instead replace them with
> XFree86 4.2.0 in NetBSD?
> In, FreeBSD, in order to do that, just don't install XFree86 that shipped
> with FreeBSD 4.x, and install one from /usr/ports/x11/XFree86-4 instead

Don't install the X shipped with NetBSD 1.5.x and get one from

Manuel Bouyer, LIP6, Universite Paris VI.