Subject: My Muck
To: None <>
From: Jason R. Fink <>
List: current-users
Date: 01/29/2002 07:38:10
Hey all,

I am running the latest i386 snapshot, cvsed src. I can buildtools
fine, a -current kernel too, but for some reason when I try to run
a build I am getting this:

rm -f grep.o dfa.o kwset.o obstack.o savedir.o getopt.o getopt1.o search.o stpcpy.o regex.o grepmat.o  grep.ln dfa.ln kwset.ln obstack.ln savedir.ln getopt.ln getopt1.ln search.ln stpcpy.ln regex.ln grepmat.ln
rm -f grep.1 grep.cat1  
rm -f a.out [Ee]rrs mklog core *.core grep
rm: grep: is a directory
*** Error code 1

nbmake: stopped in /usr/trees/20020129-UTC/gnu/usr.bin/grep
*** Error code 1

So, I rebuilt make. Did make includes. For the heck of it I tried moving
the grep directory and the same error came up on ktrace. It seems to
crop up on any srcdir that is like so:


where the utility has a sundir of the same name. I am positive I am
missing something incredibly simple here :-) Also I am running all
the default /etc/mk.conf (the snapshot does not install /etc/mk.conf
so I am assuming I am using the defaults).

Thanks in advance,


  * NetBSD: Portability, Advanced Security and Rock Solid Stability *