Subject: pthreads problem
To: None <>
From: Adam Lebsack <>
List: current-users
Date: 01/07/2002 04:59:57
Hey guys,

I recently checked out the src to build the latest NetBSD for macppc.  I 
built it on a 1.5.2-macppc system with the script, which is 
pretty slick (although I can't wait until I can build NetBSD on my MacOS 
X box, which is much faster).

Anyway,  the source was checked out from CVS on Jan 4.  I installed the 
full build today and started to do some pkgsrc compiling (pkgsrc checked 
out Jan 7).  I tried databases/mysql-server and ran into a problem with 
the mit-pthreads in there, so I tried devel/mit-pthreads.  Same exact 

cpp  -I/u1/Sandbox/obj/pkg/devel/mit-pthreads/work/pthreads-1_60_beta6 
pthreads/work/pthreads-1_60_beta6/include -DPTHREAD_KERNEL   
pthreads/work/pthreads-1_60_beta6/syscall.S > syscall.i
In file included from /u1/Sandbox/obj/pkg/devel/mit-
/usr/include/sys/cdefs.h:212: #error "No function renaming possible"
pthreads/work/pthreads-1_60_beta6/syscall.S:32: unterminated character 
*** Error code 1

make: stopped in /u1/Sandbox/obj/pkg/devel/mit-
*** Error code 1

PS, please reply to my email address as well, as I am not on the list.

Adam Lebsack