Subject: Latest dmesg output.
To: None <>
From: Glendon Gross <>
List: current-users
Date: 11/01/2001 18:41:49
Hi All,

I thought I would send my dmesg output from my custom kernel now that
I have been able to build with i686 support.   I modified the 
INSTALL kernel to produce this kernel, which seems very fast although
I am not sure how to test the i686-specific support with a Duron
processor.  I will be happy to share the kernel build file upon request.
Notice that the Promise 100Mbit controller is detected and initialized
at UDMA mode 5. (pciide1).  I am booting from this controller.   Whoever
worked on that code, thanks!!   NetBSD has superior support for this
Motherboard (an ASUS) to any other OS I have installed to date.


Glen Gross

NetBSD 1.5Y (CLONIX.i686) #5: Mon Oct 29 13:38:56 PST 2001
cpu0: AMD Duron (686-class), 655.89 MHz
cpu0: I-cache 64 KB 64b/line 2-way, D-cache 64 KB 64b/line 2-way
cpu0: L2 cache 1 KB 64b/line 16-way
cpu0: features 183f9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR>
cpu0: features 183f9ff<PGE,MCA,CMOV,FGPAT,PSE36,MMX,FXSR>
total memory = 447 MB
avail memory = 411 MB
using 5754 buffers containing 23016 KB of memory
BIOS32 rev. 0 found at 0xf0ef0
mainbus0 (root)
pci0 at mainbus0 bus 0: configuration mode 1
pci0: i/o space, memory space enabled
pchb0 at pci0 dev 0 function 0
pchb0: vendor 0x1106 product 0x0305 (rev. 0x02)
agp at pchb0 not configured
ppb0 at pci0 dev 1 function 0: vendor 0x1106 product 0x8305 (rev. 0x00)
pci1 at ppb0 bus 1
pci1: i/o space, memory space enabled
vga0 at pci1 dev 0 function 0: vendor 0x5333 product 0x8a13 (rev. 0x02)
wsdisplay0 at vga0: console (80x25, vt100 emulation)
wsdisplay0: screen 1-7 added (80x25, vt100 emulation)
pcib0 at pci0 dev 4 function 0
pcib0: vendor 0x1106 product 0x0686 (rev. 0x22)
pciide0 at pci0 dev 4 function 1: VIA Technologies VT82C686A (Apollo KX133) ATA66 controller
pciide0: bus-master DMA support present
pciide0: primary channel configured to compatibility mode
pciide0: disabling primary channel (no drives)
pciide0: secondary channel configured to compatibility mode
pciide0: disabling secondary channel (no drives)
uhci0 at pci0 dev 4 function 2: vendor 0x1106 product 0x3038 (rev. 0x10)
uhci0: interrupting at irq 5
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: vendor 0x1106 UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1 at pci0 dev 4 function 3: vendor 0x1106 product 0x3038 (rev. 0x10)
uhci1: interrupting at irq 5
usb1 at uhci1: USB revision 1.0
uhub1 at usb1
uhub1: vendor 0x1106 UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
pchb1 at pci0 dev 4 function 4
pchb1: vendor 0x1106 product 0x3057 (rev. 0x30)
ahc1 at pci0 dev 9 function 0
ahc1: interrupting at irq 5
ahc1: aic7860 Single Channel A, SCSI Id=7, 3/255 SCBs
scsibus0 at ahc1: 8 targets, 8 luns per target
fxp0 at pci0 dev 12 function 0: i82559 Ethernet, rev 8
fxp0: interrupting at irq 10
fxp0: Ethernet address 00:03:47:0a:44:3a
inphy0 at fxp0 phy 1: i82555 10/100 media interface, rev. 4
inphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
pciide1 at pci0 dev 17 function 0: Promise Ultra100/ATA Bus Master IDE Accelerator (rev. 0x02)
pciide1: bus-master DMA support present
pciide1: primary channel configured to native-PCI mode
pciide1: using irq 7 for native-PCI interrupt
wd0 at pciide1 channel 0 drive 0: <WDC WD200BB-00AUA1>
wd0: drive supports 16-sector PIO transfers, LBA addressing
wd0: 19092 MB, 16383 cyl, 16 head, 63 sec, 512 bytes/sect x 39102336 sectors
wd0: 32-bit data port
wd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 5 (Ultra/100)
wd0(pciide1:0:0): using PIO mode 4, Ultra-DMA mode 5 (Ultra/100) (using DMA data transfers)
pciide1: secondary channel configured to native-PCI mode
pciide1: disabling secondary channel (no drives)
isa0 at pcib0
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
pckbc0 at isa0 port 0x60-0x64
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd at pckbd0 not configured
pcppi0 at isa0 port 0x61
sysbeep0 at pcppi0
isapnp0 at isa0 port 0x279: ISA Plug 'n Play device support
npx0 at isa0 port 0xf0-0xff: using exception 16
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB, 80 cyl, 2 head, 18 sec
isapnp0: no ISA Plug 'n Play devices found
biomask fbe5 netmask ffe5 ttymask ffe7
scsibus0: waiting 2 seconds for devices to settle...
sd0 at scsibus0 target 1 lun 0: <CONNER, CP30540  SUN0535, B0CD> SCSI2 0/direct fixed
sd0: 517 MB, 2242 cyl, 6 head, 78 sec, 512 bytes/sect x 1059528 sectors
sd0: sync (100.0ns offset 15), 8-bit (10.000MB/s) transfers, tagged queueing
cd0 at scsibus0 target 3 lun 0: <TOSHIBA, CD-ROM XM-5701TA, 0167> SCSI2 5/cdrom removable
cd0: sync (100.0ns offset 8), 8-bit (10.000MB/s) transfers
uhub2 at uhub1 port 2
uhub2: ALCOR Generic USB Hub, class 9/0, rev 1.10/1.00, addr 2
uhub2: 4 ports with 4 removable, self powered
sd0: no disk label
boot device: wd0
root on wd0a dumps on wd0b
sd0: no disk label
sd0: no disk label