Subject: Re: problem in etc/Makefile ?
To: Todd Vierling <>
From: George Coulouris <>
List: current-users
Date: 10/31/2001 13:18:36
On Wed, Oct 31, 2001 at 01:04:59PM -0500, Todd Vierling wrote:
> On Wed, 31 Oct 2001, George Coulouris wrote:
> : Strangely, explicitly specifying USE_NEW_TOOLCHAIN=yes and USETOOLS=yes made
> : that problem go away. I was under the impression that both of these were
> : now the default.
> Only on i386 and sparc64 -- plus, if you have old /usr/share/mk, unless you
> specify "make -m /usr/src/share/mk", you may get the wrong bsd.*.mk files.

I'm building i386 on i386, and my /usr/share/mk is from my Oct 26 build. For
good measure, I ran with -m /usr/src/share/mk to grab the handful of files
that have been touched since then, and I still get:

dependall ===> libc
/usr/tooldir/bin/i386--netbsdelf-lint -chapbxzF -w -X 272 -d
/usr/destdir/usr/include -D_LIBC -DNLS -DYP -DHESIOD -DLIBC_SCCS
-DSYSLIBC_SCCS -D_REENTRANT -I/usr/src/lib/libc/include -DINET6
-D__DBINTERFACE_PRIVATE -I/usr/src/lib/libc/../../libexec/ld.elf_so
-I/usr/src/lib/libc/dlfcn -DWITH_RUNE -DRUNEMOD_MAJOR=3
-D_PATH_LOCALEMODULE=\"/usr/lib/runemodule\" -DRESOLVSORT -I.
-DPOSIX_MISTAKE -DPORTMAP -DFLOATING_POINT -i /usr/src/lib/libc/net/base64.c
/usr/src/lib/libc/net/base64.c:54: arpa/inet.h: No such file or directory
/usr/src/lib/libc/net/base64.c:55: arpa/nameser.h: No such file or directory
*** Error code 1

I suppose these errors lie outside the scope of the toolchain, though.