Subject: Darwin support added to pkgsrc
To: None <>
From: Alistair Crooks <>
List: current-users
Date: 10/30/2001 15:40:53
I've just added initial support for Darwin (1.4) to pkgsrc, with
many thanks to Bill Coldwell for giving me the opportunity to do

Whilst it's very early days, as yet, I have actually been able to
install packages on Darwin. I haven't yet tried any of the "biggies"
like gnome or kde, but I thought I'd commit the changes so that
others can perhaps help me out with those.

To use this on Darwin, you'll need a pkgsrc with the Darwin changes
in, and you'll also need the bootstrap kit:

Extract this tarball, and you'll get everything under a bootstrap-pkgsrc
directory.  cd into that directory, and execute "./bootstrap" as
root (it installs things under the ${LOCALBASE} hierarchy).

bootstrap has certain defaults, which can be changed using command
line switches:

pkgdir (defaults to /usr/pkg) can be set using --pkgdir=/some/dir
pkgdbdir (defaults to /var/db/pkg) can be set using --pkgdbdir=/some/dir
pkgsrcdir (defaults to /pkgsrc) can be set using --pkgsrcdir=/some/dir

It will bootstrap bmake (NetBSD's make, the bsdmake in /usr/bin
doesn't understand :C modifiers in ${VAR:C/old/new/}), install
NetBSD *.mk files in ${pkgdir}/share/mk, lukemftp-1.5, and the
digest and pkg_install packages.

Alistair Crooks