Subject: Re: wi0: device timeout
To: William Waites <>
From: Kevin Lahey <>
List: current-users
Date: 10/24/2001 13:26:17
In message <>William Waites writes
>with -current, i have dlink dwl-650 card working well in a pci cardbus
>bridge of unknown origin. however i have noticed some strange behaviour
>when a linux box with a wireless card comes up in bss mode -- it 
>knocks the dlink card off the air, and iwconfig gives invalid
>argument complaints untill the card is removed and re-inserted.
>a netbsd laptop with the same wireless card in bss mode causes no

Ever since I put a Orinoco PCI adaptor and Buffalo card into my
-current machine, I've been experiencing around two lockups or 
spontaneous reboots a day.  Since I've got some weird mobile
IPv6 code in there, and I'm running XFree86-current, I figured
I had enough complicating factors to make it tough to point a 
finger (or file a pr).  I swapped slots multiple times, and 
tried specifying a fixed IRQ in the BIOS.  If anybody has any 
debugging tips, I'm all ears!

cbb0 at pci2 dev 11 function 0: Texas Instruments PCI1410 PCI-CardBus Bridge (rev. 0x01)
cbb0: interrupting at irq 3
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 3 device 0 cacheline 0x8, lattimer 0x20
pcmcia0 at cardslot0
wi0 at pcmcia0 function 0: MELCO, WLI-PCM-L11, Version 01.01
wi0: 802.11 address 00:60:1d:f6:19:b5
wi0: using Lucent chip or unknown chip

Other than the reboots, it's worked pretty well for me.  Linux
can't seem to find the card at all.

Good luck,