Subject: Re: 3Com 3c589 - worked in 1.4.2, doesn't work now
To: John Nemeth <>
From: Manuel Bouyer <>
List: current-users
Date: 07/14/2001 12:49:46
On Fri, Jul 13, 2001 at 06:04:06PM -0700, John Nemeth wrote:
>      I have a 3Com 3c589 PCMCIA ethernet card that worked perfectly
> fine under NetBSD 1.4.2 on my laptop.  I recently tried upgrading to
> 1.4.3 (the laptop is only a 486sx/33 with 8M RAM, so I'm not sure I
> want to run 1.5 on it), and the card no longer works.  The first
> problem is that it was failing the TX_THRESH_AVAIL test (reading the
> register returned 0x701).  I fixed this by quickly hacking in a check

Did you check I/O range used on 1.4.2 and 1.4.3 ?

Manuel Bouyer <>