Subject: 3Com 3c589 - worked in 1.4.2, doesn't work now
To: None <>
From: John Nemeth <>
List: current-users
Date: 07/13/2001 18:04:06
     I have a 3Com 3c589 PCMCIA ethernet card that worked perfectly
fine under NetBSD 1.4.2 on my laptop.  I recently tried upgrading to
1.4.3 (the laptop is only a 486sx/33 with 8M RAM, so I'm not sure I
want to run 1.5 on it), and the card no longer works.  The first
problem is that it was failing the TX_THRESH_AVAIL test (reading the
register returned 0x701).  I fixed this by quickly hacking in a check
for the value my card returns.  More details later.  I now have a
problem with reading the EEPROM.  It is giving me an address of
00:ff:4b:ff:2b:ff.  Also, my 8KB FIFO seems to have magically turned
into a 512KB FIFO (neat trick!).  I seem to remember a discussion some
time ago about the bad address, but I'm having trouble finding it in
the archives.  I also looked at all the changes that were made to
/sys/dev/ic/elink3.c and didn't see anything that looked related.  Does
anybody know how I can get my ethernet card working again?

     Before I sent this, I decided to try booting NetBSD 1.5 and NetBSD
1.5.1.  They both fail with the TX_AVAIL_THRESH problem, so no joy
there either.  I note that the TX_AVAIL_THRESH test hasn't been changed
in quite a while, so I doubt -current would work.