Subject: Re: Timestamping for dmesg output?
To: Aaron J. Grier <firstname.lastname@example.org>
From: Mike Cheponis <mac@Wireless.Com>
Date: 07/03/2001 15:55:14
Sorry, I was clearly sleep-deprived.
It's dmesg that leaves that stuff off.
Note that the dmesg man page is therefore inaccurate:
MESG(8) NetBSD System Manager's Manual DMESG(8)
dmesg - display the system message buffer
dmesg [-M core] [-N system]
dmesg displays the contents of the system message buffer.
The options are as follows:
-M Extract values associated with the name list from the specified
core instead of the default ``/dev/mem''.
-N Extract the name list from the specified system instead of the
/var/run/dmesg.boot copy of dmesg at the time of last boot.
The dmesg command appeared in 4.0BSD.
4th Berkeley Distribution June 5, 199
As, in fact, it actually displays the system message buffer sans timestamps.
Thanks again -Mike
On Tue, 3 Jul 2001, Aaron J. Grier wrote:
> Date: Tue, 3 Jul 2001 14:57:51 -0700
> From: Aaron J. Grier <email@example.com>
> To: firstname.lastname@example.org
> Subject: Re: Timestamping for dmesg output?
> On Tue, Jul 03, 2001 at 02:50:54PM -0700, Mike Cheponis wrote:
> > Hi,
> > I recently had a problem where messages were reported to /var/log/messages
> > but it would have been very helpful to have the messages time-stamped.
> > Does an option already exist to do this? It seems like it would be both
> > easy to do and useful.
> eh? all messages in the dmesg buffer go through syslog to get to
> /var/log/messages, and syslogd does timestamps.
> Aaron J. Grier | "Not your ordinary poofy goof." | email@example.com