Subject: Weird rlogin crash just now...
To: None <>
From: Kevin P. Neal <>
List: current-users
Date: 06/16/2001 23:59:16
I just had an odd experience. I'm bringing my boxes back up
after a particularly nasty thunderstorm (gotta love tropical
storms, or whatever they callthem). My main Alpha is up and I
had just gotten my PC (the only working X server in the house)

I logged into the Alpha ("tome") from the PC ("stopgap") with 
rlogin in one of my xterms. Got a password prompt, typed my
password, and was in. No big deal.

Then I tried rlogin from the other xterm on screen. As I was doing
this Netscape was in the process of starting, so the computer was
groaning in agony as I was trying to use rlogin. This is what 

stopgap% rlogin tome
rlogin: Undefined PLT symbol "read" (reloc type = 7, symnum = 30)
                                                                 Password:stopgap% stopgap%

My terminal must have been in a weird state because return produced
more prompts from my shell but no newlines or carriage returns were 
printed. Fine. I can type rlogin blind. So I did. I got a password
prompt, entered my password, and was in. 

Just as I was finishing this email I had this pop up in the problem
xterm (with a few extra lines for context):

  888   d88' `88b `888P"Y88bP"Y88b  d88' `88b 
  888   888   888  888   888   888  888ooo888 
  888 . 888   888  888   888   888  888    .o 
  "888" `Y8bod8P' o888o o888o o888o `Y8bod8P' 
You have mail.

tome% Login timed out after 300 seconds
rlogin: connection closed.

Oh, my latest rlogin (you know, the one that worked) is still logged
in and working fine. 

So, right now I'm not even sure which machine puked: the server or the
client. And I've never seen rlogin on either platform crash with PLT
errors, so I have no idea what caused that. 

Any ideas?
Kevin P. Neal                      

"Nonbelievers found it difficult to defend their position in \ 
    the presense of a working computer." -- a DEC Jensen paper