Subject: Re: Reminder: 1.5.1_xxx still has TGA2/PowerStorm 4d20 problems/panic
To: None <>
From: R. C. Dowdeswell <>
List: current-users
Date: 05/21/2001 23:08:07
On 990302367 seconds since the Beginning of the UNIX epoch
Markus W Kilbinger wrote:

>I only have _one_ alpha which is equipped with the 4d20 and runs
>NetBSD 1.4.3 at the moment.
>-> How to upgrade to 1.5.1... (or better -current?) in this situation?
>Is it possible to compile a 1.5.1... kernel and userland with an
>existing 1.4... system? (No alpha cross package in pkgsrc)
>Otherwise I need an inst ramdisk and a generic kernel without the tga
>stuff, I guess...

You should be able to just build a kernel for 1.5.1 out of 1.4.3.  I
think taht the toolchains are the same.  The syssrc module from
anon-cvs should have all of the bits in it that you need to do
that.  You probably need to use the newer config (which is in

Then, depending on your upgrade method (my prefered method is by
hand), you can boot the new kernel which is perfectly capable of
running old userland, and just unpack the ditribuition tarballs
over you running system.  Be careful to use the --unlink option to
tar and the -p option.

Also, do not forget to save the old kernel in case of problems,
and squirrel away your etc so that you can hand compare the

Then reboot and all should be good.  :-)

 == Roland Dowdeswell                      http://www.Imrryr.ORG/~elric/  ==
 == The Unofficial NetBSD Web Pages        http://www.Imrryr.ORG/NetBSD/  ==
 == The NetBSD Project                            http://www.NetBSD.ORG/  ==