Subject: Re: Getting current install floppies
To: Frank van der Linden <>
From: Paul Hoffman <>
List: current-users
Date: 05/18/2001 11:18:21
At 12:32 PM +0200 5/18/01, Frank van der Linden wrote:
>Okay.. last attempt: in
>there's a bootA and bootB 2-floppy set. Both have AHC_ALLOW_MEMIO and
>PCI power state code added to ahc_pci.c. bootA has the PCIBIOS_* options
>and an artificial maxbus set to 3. bootB does not have that.

Thanks for keeping in on this! I really do appreciate it 
(particularly after seeing the s/n ratio on the FreeBSD mailing 

I get the same results for both bootA and bootB:

I think I saw ahc1: and ahc2: get set up properly. There are messages 
that look like they talk about "wide channel A" and targets and so 
on, and nothing that struck me as an error. Again, I apologize, but 
the messages zoom by too quickly for me to report much more.

Then after the 2-second SCIS wait, the screen scrolls unendingly with 
the message:

ahc1: Spurious SCSI interrupt

The system does this forever.

Unfortunately, console redirection with "consdev com0" doesn't 
capture the messages. On the redirected console, I get the "Please 
remove disk 1...", and then the spinning cursor and 
"+190900=0x4b558c" and then nothing; none of the booting sequence 
beyond that appears on the redirected console.

>If you successfully install FreeBSD, please send the FreeBSD dmesg output,
>I'd like to see which buses it finds.

Here's the dmesg for FreeBSD 4.3:

Copyright (c) 1992-2001 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
         The Regents of the University of California. All rights reserved.
FreeBSD 4.3-RELEASE #0: Sat Apr 21 10:54:49 GMT 2001
Timecounter "i8254"  frequency 1193182 Hz
CPU: Pentium III/Pentium III Xeon/Celeron (860.89-MHz 686-class CPU)
   Origin = "GenuineIntel"  Id = 0x686  Stepping = 6
real memory  = 268369920 (262080K bytes)
avail memory = 256921600 (250900K bytes)
Preloaded elf kernel "kernel" at 0xc044d000.
Pentium Pro MTRR support enabled
md0: Malloc disk
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib1: <ServerWorks host to PCI bridge> on motherboard
pci1: <PCI bus> on pcib1
pcib0: <ServerWorks host to PCI bridge> on motherboard
pci0: <PCI bus> on pcib0
fxp0: <Intel Pro 10/100B/100+ Ethernet> port 0xecc0-0xecff mem 
0xfe100000-0xfe1fffff,0xfe2ff000-0xfe2fffff irq 11 at device 1.0 on 
fxp0: Ethernet address 00:b0:d0:de:5d:de
fxp1: <Intel Pro 10/100B/100+ Ethernet> port 0xec80-0xecbf mem 
0xfe000000-0xfe0fffff,0xfe2fe000-0xfe2fefff irq 10 at device 2.0 on 
fxp1: Ethernet address 00:b0:d0:de:5d:df
pci0: <ATI Mach64-GR graphics accelerator> at 3.0
isab0: <ServerWorks IB6566 PCI to ISA bridge> at device 15.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <ServerWorks ROSB4 ATA33 controller> port 0x8b0-0x8bf at 
device 15.1 on pci0
ata0: at 0x1f0 irq 14 on atapci0
ohci0: <OHCI (generic) USB controller> mem 0xfe2fc000-0xfe2fcfff irq 
7 at device 15.2 on pci0
usb0: OHCI version 1.0, legacy support
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: (unknown) OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 4 ports with 4 removable, self powered
pcib2: <ServerWorks host to PCI bridge> on motherboard
pci2: <PCI bus> on pcib2
ahc0: <Adaptec aic7899 Ultra160 SCSI adapter> port 0xdc00-0xdcff mem 
0xfeaff000-0xfeafffff irq 5 at device 5.0 on pci2
aic7899: Wide Channel A, SCSI Id=7, 32/255 SCBs
ahc1: <Adaptec aic7899 Ultra160 SCSI adapter> port 0xd800-0xd8ff mem 
0xfeafe000-0xfeafefff irq 3 at device 5.1 on pci2
aic7899: Wide Channel B, SCSI Id=7, 32/255 SCBs
pcib3: <ServerWorks host to PCI bridge> on motherboard
pci3: <PCI bus> on pcib3
fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1: configured irq 3 not in bitmap of probed irqs 0
ppc0: parallel port not found.
acd0: CDROM <SAMSUNG CD-ROM SN-124> at ata0-master using PIO4
Waiting 15 seconds for SCSI devices to settle
pass1 at ahc0 bus 0 target 6 lun 0
pass1: <DELL 1x3 U2W SCSI BP 1.21> Fixed Processor SCSI-2 device
pass1: 3.300MB/s transfers
da0 at ahc0 bus 0 target 0 lun 0
da0: <SEAGATE ST336704LC 0004> Fixed Direct Access SCSI-3 device
da0: 160.000MB/s transfers (80.000MHz, offset 63, 16bit), Tagged 
Queueing Enabled
da0: 34732MB (71132960 512 byte sectors: 255H 63S/T 4427C)
Mounting root from ufs:/dev/da0s1a