Subject: kernel won't start on i386
To: None <>
From: Jim Bernard <>
List: current-users
Date: 05/11/2001 10:28:25
Has anybody had any success in the past few days getting an i386 kernel
to boot?  I've tried with sources updated on each of the last 3 days, to
no avail.  I tried building a GENERIC kernel today to verify that it wasn't
something specific to my kernel config, and that didn't work either.

All I get when I try to boot is the bootloader message (this from a custom
config; GENERIC does the same, but the numbers are different, of course):

  booting wd0a:netbsd - starting in 0
  2422950+35300+168700 [65+129968+94525]=0x2b9498
  [stops here after CRLF--no further output]

The currently working kernel is 1.5S from March 15, and I also successfully
booted the 1.5T GENERIC kernel from the April 7 snapshot.

The system is a pentium pro 200 (dmesg from April 7 snapshot kernel):

NetBSD 1.5T (GENERIC) #2: Sun Apr  8 19:14:04 PDT 2001
cpu0: Intel Pentium Pro (686-class), 199.45 MHz
cpu0: I-cache 8K 32b/line 4-way, D-cache 8K 32b/line 2-way
cpu0: L2 cache 256K 32b/line 4-way
cpu0: features f9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR>
cpu0: features f9ff<PGE,MCA,CMOV>
total memory = 127 MB
avail memory = 112 MB
using 1659 buffers containing 6636 KB of memory
BIOS32 rev. 0 found at 0xfd8e0
mainbus0 (root)
pci0 at mainbus0 bus 0: configuration mode 1
pci0: i/o space, memory space enabled
pchb0 at pci0 dev 0 function 0
pchb0: Intel 82441FX PCI and Memory Controller (PMC) (rev. 0x02)
pcib0 at pci0 dev 7 function 0
pcib0: Intel 82371SB PCI-to-ISA Bridge (PIIX3) (rev. 0x01)
pciide0 at pci0 dev 7 function 1: Intel 82371SB IDE Interface (PIIX3) (rev. 0x00)
pciide0: bus-master DMA support present
pciide0: primary channel wired to compatibility mode
wd0 at pciide0 channel 0 drive 0: <ST34321A>
wd0: drive supports 32-sector PIO transfers, LBA addressing
wd0: 4103 MB, 8894 cyl, 15 head, 63 sec, 512 bytes/sect x 8404830 sectors
wd0: 32-bit data port
wd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 2 (Ultra/33)
pciide0: primary channel interrupting at irq 14
wd0(pciide0:0:0): using PIO mode 4, DMA mode 2 (using DMA data transfers)
pciide0: secondary channel wired to compatibility mode
atapibus0 at pciide0 channel 1
cd0 at atapibus0 drive 0: <TOSHIBA CD-ROM XM-5602B, 2100116854, 1796> type 5 cdro
m removable
cd0: 32-bit data port
cd0: drive supports PIO mode 3, DMA mode 1
pciide0: secondary channel interrupting at irq 15
cd0(pciide0:1:0): using PIO mode 0, DMA mode 1 (using DMA data transfers)
vga1 at pci0 dev 15 function 0: ATI Technologies Mach64 GT (rev. 0x41)
wsdisplay0 at vga1: console (80x25, vt100 emulation)
ex0 at pci0 dev 19 function 0: 3Com 3c905B-TX 10/100 Ethernet (rev. 0x24)
ex0: interrupting at irq 11
ex0: MAC address 00:10:4b:76:a2:63
exphy0 at ex0 phy 24: 3Com internal media interface
exphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
isa0 at pcib0
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
pckbc0 at isa0 port 0x60-0x64
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
lpt0 at isa0 port 0x378-0x37b irq 7
pcppi0 at isa0 port 0x61
midi0 at pcppi0: PC speaker
sysbeep0 at pcppi0
isapnp0 at isa0 port 0x279: ISA Plug 'n Play device support
npx0 at isa0 port 0xf0-0xff: using exception 16
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB, 80 cyl, 2 head, 18 sec
isapnp0: read port 0x203
isapnp0: <ENSONIQ SoundscapeVIVO, ENS1011, , > port 0x330/16,0x530/8,0x2100/64 ir
q 5,9 drq 1,0 not configured
joy0 at isapnp0 port 0x200/8
joy0: ENSONIQ SoundscapeVIVO
joy0: joystick not connected
biomask e765 netmask ef65 ttymask ffe7
boot device: wd0
root on wd0a dumps on wd0b
root file system type: ffs
wsdisplay0: screen 1 added (80x25, vt100 emulation)
wsdisplay0: screen 2 added (80x25, vt100 emulation)
wsdisplay0: screen 3 added (80x25, vt100 emulation)
wsdisplay0: screen 4 added (80x25, vt100 emulation)
wsmux1: connecting to wsdisplay0