Subject: tested the 1.5.1_BETA snapshot on a laptop.. with problems
To: None <>
From: Tim Rightnour <>
List: current-users
Date: 04/15/2001 23:42:51
A friend of mine has one of those wierd laptops that requires the
PCIC_ISA_ALLOC stuff in the kernel config in order to have the pcmcia stuff
work.  When upgrading his machine from 1.5 to 1.5.1BETA, I thought I would try
the kern-laptop.tgz kernel.  This didn't work so well.

The kern-laptop kernel, while probing all the pcmcia stuff correctly, and not
having any quirks in that department, would loop forever trying to downgrade
the pciide from DMA to PIO mode 4.

however.. the 1.5.1BETA GENERIC standard kernel, would boot, and downgrade
fine. (unfortunately, that leaves the PCIC problem)

I can config a kernel to get around this.. but thought someone should be made
aware of it.

Tim Rightnour <>
NetBSD: Free multi-architecture OS
NetBSD supported hardware database: