Subject: Re: 1.5R botched ld.elf_so ?
To: None <>
From: maximum entropy <>
List: current-users
Date: 04/10/2001 20:43:52
>Date: Tue, 10 Apr 2001 21:57:01 +0000
>From: heasley <>
>Mon, Apr 09, 2001 at 08:53:19PM -0400, maximum entropy:
>> >Date: Mon, 9 Apr 2001 21:29:06 +0000
>> >From: john heasley <>
>> >
>> >i'm still having trouble with ld.elf_so (on sparc), with 1.5T source
>> >from ~last friday.  all dynamically linked executables core dump.  any
>> >clues to as to what might cause what would appear to be an error in
>> >relocation?  does anyone else have this problem?
>> Hmm...let me have LD_RUN_PATH set in your environment
>> where you build ld.elf_so.  I reported this over a year ago, but no
>> one seems to have looked at the PR, much less applied the simple patch
>> I supplied...
>bingo.  that worked.  was

Just to clarify, having LD_LIBRARY_PATH set is OK.  ld.elf_so will be
built incorrectly only if LD_RUN_PATH is set.  Different variable.
Since it worked for you, I assume you actually cleared LD_RUN_PATH to
rebuild but typed LD_LIBRARY_PATH into your email message...

entropy -- it's not just a good idea, it's the second law.