Subject: Failure to boot -current kernel
To: None <>
From: Robert Evans <>
List: current-users
Date: 04/01/2001 21:09:51
Hi all,

I've been scratching my head against this for a couple of days and
would appreciate any input.

I'm running a 1.5R kernel on my laptop, built from sources retrieved on
Feb 11th.  Things are fine and dandy, but when I try to build a new
kernel from recent sources (recent being within the last couple of
days, I can't be more exact over when the problem started as this is
the first time I've tried a build since the kernel that is currently
working), the box reboots as soon as the bootloader has finished
loading the new kernel.  No panic messages, not even a copyright
message, just the sizes and then a blank screen before it starts all
over again.

I've tried updating the bootloader from 2.6 to 2.8, and as a bit of
voodoo tried the downgrades to locore.s and trap.c that other people
have had problems with, neither of which has made any difference.  The
problem repeats with either my "usual" custom config kernel or a
GENERIC kernel, and I've also pulled a fresh syssrc tree in case there
was some subtle corruption in the old one.

The laptop is a Dell CPx650J (650MHz Mobile PIII) with 128MB of RAM.

Any ideas?  I'm really at a loss of where to go from here, as nothing
gets far enough for DDB or DEBUG/DIAGNOSTIC to give any help.  Appended
are the boot messages from the successful 1.5R kernel.


NetBSD 1.5R (DIZIET) #3: Sun Feb 11 17:24:42 GMT 2001
cpu0: Intel Pentium III (Coppermine) (686-class), 648.04 MHz
cpu0: I-cache 16K 32b/line 4-way, D-cache 16K 32b/line 2/4-way
cpu0: L2 cache 256K 32b/line 8-way
cpu0: features 383f9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR>
cpu0: features 383f9ff<PGE,MCA,CMOV,FGPAT,PSE36,MMX,FXSR,XMM>
total memory = 127 MB
avail memory = 114 MB
using 1658 buffers containing 6632 KB of memory
BIOS32 rev. 0 found at 0xffe90
PCI BIOS rev. 2.1 found at 0xfc0ce
PCI IRQ Routing Table rev. 1.0 found at 0xfbd70, size 128 bytes (6 entries)
PCI Interrupt Router at 000:07:0 (vendor 0x8086 product 0x1234)
pci_addr_fixup: 000:03:0 0x104c 0xac1c new address 0x08000000
pci_addr_fixup: 000:03:1 0x104c 0xac1c new address 0x08001000
mainbus0 (root)
pci0 at mainbus0 bus 0: configuration mode 1
pci0: i/o space, memory space enabled
pchb0 at pci0 dev 0 function 0
pchb0: vendor 0x8086 product 0x7190 (rev. 0x03)
ppb0 at pci0 dev 1 function 0: vendor 0x8086 product 0x7191 (rev. 0x03)
pci1 at ppb0 bus 1
pci1: i/o space, memory space enabled
vga1 at pci1 dev 0 function 0: vendor 0x1002 product 0x4c4d (rev. 0x64)
wsdisplay0 at vga1: console (80x25, vt100 emulation)
cbb0 at pci0 dev 3 function 0: vendor 0x104c product 0xac1c (rev. 0x01)
cbb1 at pci0 dev 3 function 1: vendor 0x104c product 0xac1c (rev. 0x01)
pcib0 at pci0 dev 7 function 0
pcib0: vendor 0x8086 product 0x7110 (rev. 0x02)
pciide0 at pci0 dev 7 function 1: Intel 82371AB IDE controller (PIIX4) (rev. 0x01)
pciide0: bus-master DMA support present
pciide0: primary channel wired to compatibility mode
wd0 at pciide0 channel 0 drive 0: <IBM-DARA-212000>
wd0: drive supports 16-sector PIO transfers, LBA addressing
wd0: 11513 MB, 16383 cyl, 16 head, 63 sec, 512 bytes/sect x 23579136 sectors
wd0: 32-bit data port
wd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 4 (Ultra/66)
pciide0: primary channel interrupting at irq 14
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2 (Ultra/33) (using DMA data transfers)
pciide0: secondary channel wired to compatibility mode
atapibus0 at pciide0 channel 1
cd0 at atapibus0 drive 0: <TOSHIBA DVD-ROM SD-C2302, 2000000057, 1013> type 5 cdrom removable
cd0: 32-bit data port
cd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 2 (Ultra/33)
pciide0: secondary channel interrupting at irq 15
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2 (Ultra/33) (using DMA data transfers)
uhci0 at pci0 dev 7 function 2: vendor 0x8086 product 0x7112 (rev. 0x01)
uhci0: interrupting at irq 11
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: vendor 0x8086 UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
vendor 0x8086 product 0x7113 (miscellaneous bridge, revision 0x03) at pci0 dev 7 function 3 not configured
vendor 0x125d product 0x1998 (audio multimedia, revision 0x10) at pci0 dev 8 function 0 not configured
cbb0: interrupting at irq 11
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 2 device 0 cacheline 0x8, lattimer 0x20
pcmcia0 at cardslot0
cbb1: interrupting at irq 11
cardslot1 at cbb1 slot 1 flags 0
cardbus1 at cardslot1: bus 3 device 0 cacheline 0x8, lattimer 0x20
pcmcia1 at cardslot1
isa0 at pcib0
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
pckbc0 at isa0 port 0x60-0x64
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
lpt0 at isa0 port 0x378-0x37b irq 7
pcppi0 at isa0 port 0x61
sysbeep0 at pcppi0
isapnp0 at isa0 port 0x279: ISA Plug 'n Play device support
npx0 at isa0 port 0xf0-0xff: using exception 16
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
isapnp0: no ISA Plug 'n Play devices found
apm0 at mainbus0: Power Management spec V1.2
biomask ef6d netmask ef6d ttymask ffef
tlp0 at cardbus1 dev 0 function 0: Xircom X3201-3 Ethernet, pass 0.3
tlp0: Ethernet address 00:10:a4:d1:64:dc
tqphy0 at tlp0 phy 0: 78Q2120 10/100 media interface, rev. 10
tqphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
com3 at cardbus1 dev 0 function 1: Xircom CardBus Ethernet 10/100 + Modem 56
com3: ns16550a, working fifo
boot device: wd0
root on wd0a dumps on wd0b
root file system type: ffs