Subject: Re: X problems
To: D'Arcy J.M. Cain <>
From: Jukka Marin <>
List: current-users
Date: 03/15/2001 13:15:20
On Thu, Mar 15, 2001 at 05:54:03AM -0500, D'Arcy J.M. Cain wrote:
> First of all I am using a Rage 128 AGP card.  XFree86 uses the SVGA
> driver.  Every once in a while, especially when fast scrolling, the
> text meant for an xterm will be displayed at some random spot on the
> screen.  I changed cards when I upgraded so it is hard to tell for
> sure if it is the card or the software.

Sounds familiar.. I think I've seen similar problems with my Rage card.
I'm back to using a Matrox now and the problems are gone.  I thought it
was a software problem - maybe it's a bug in the Rage driver in XFree?

> Another problem is that the mouse will not use the middle button.  I
> have this same mouse at work with a current NetBSD and it works fine.
> The relevant lines from my XF86Config file are;
> Section "Pointer"
>     Protocol    "wsmouse"
>     Device      "/dev/wsmouse0"
> Any other options I tried cause it to fail with a configuration error.
> The mouse is a wheel mouse.  I tried enabling options Buttons 5 and
> ZAxismapping 4 5 but that also caused a configuration error.

Protocol    "wsmouse"
Device      "/dev/wsmouse0"
ZAxisMapping 4 5

is all I have and it Just Works with a cheap Trekker wheel mouse.  The
wheel works as well.