Subject: X problems
To: None <>
From: D'Arcy J.M. Cain <>
List: current-users
Date: 03/15/2001 05:54:03
I am having strange problems with my new system.  I have supped and built
all the latest stuff including the xsrc stuff a few times and I still have
problems.  In fact it got worse after the last build.  Can someone please
point out to me what I am doing wrong.  This is on i386.

First of all I am using a Rage 128 AGP card.  XFree86 uses the SVGA
driver.  Every once in a while, especially when fast scrolling, the
text meant for an xterm will be displayed at some random spot on the
screen.  I changed cards when I upgraded so it is hard to tell for
sure if it is the card or the software.

Another problem is that the mouse will not use the middle button.  I
have this same mouse at work with a current NetBSD and it works fine.
The relevant lines from my XF86Config file are;

Section "Pointer"
    Protocol    "wsmouse"
    Device      "/dev/wsmouse0"

Any other options I tried cause it to fail with a configuration error.

The mouse is a wheel mouse.  I tried enabling options Buttons 5 and
ZAxismapping 4 5 but that also caused a configuration error.

Now I have rebuilt the xsrc and it got worse.  Now I can't even cut and
paste.  Although the middle button doesn't work I have been able to use
the first and third buttons to emulate that.  Now that has stopped
working too.

So what can I be doing that's so wrong?

D'Arcy J.M. Cain <darcy@{druid|vex}.net>   |  Democracy is three wolves                |  and a sheep voting on
+1 416 425 1212     (DoD#0082)    (eNTP)   |  what's for dinner.