Subject: Re: CD Writer failure
To: SUNAGAWA Keiki <>
From: Dave Burgess <>
List: current-users
Date: 03/12/2001 02:00:19
Domo Sunagawa-san,

Please see below:

> Dave Burgess <> wrote:
> Dave> I looked at the SCSI code in the kernel, and that lack
> Dave> of astonishment is reasonable, since the code for
> Dave> command 0x25 basically says "this is a ROM - of course
> Dave> there's no space" and returns automatically.
> I'm not sure it's related to your problem or not, but I have
> an experience that SONY CD-R drives' return code depends on
> what kind of medium is in it, such as a fresh CD-R, written
> CD-R, CD-ROM, or empty.

I am using Maxell CD-R74 media for writing.  They fail consistenly.

I used to have this drive working and I wrote several CDs.  After
I upgraded from 1.3 to 1.4 (and upgraded cdrecord), it stopped 
working, and it is becoming important to me to get it working again.

> Dave> I've tried /dev/scgx, /dev/su0-2-0, 'cdrecord
> Dave> dev=2,0', setting up a /etc/defaults/cdrecord file
> Dave> (linked to /dev/default, to match the cdrecord
> Dave> package).  If anyone else has a suggestion, I'd sure
> Dave> be glad to hear it.
> I used 'dev=/dev/cd0d' for i386, 'dev=/dev/cd0c' for other
> architectures.

Since I am using the i386 platform, I tried /dev/cd0d and /dev/rcd0d, 
as well as /dev/cd0a and /dev/rcd0a.  All of them return precisely
the same error (the one from the original message).

Also, I forgot to mention that the drive does respond correctly to
"cdrecord -checkdrive" without a disk in the drive or with a regular
pressed CD in the drive.

Cdrecord 1.9 (i386-unknown-netbsd1.5.1.) Copyright (C) 1995-2000 Joerg Schilling
scsidev: '0,2,0'
scsibus: 0 target: 2 lun: 0
Using libscg version 'schily-0.1'
Device type    : Removable CD-ROM
Version        : 2
Response Format: 2
Capabilities   : SYNC LINKED 
Vendor_info    : 'SONY    '
Identifikation : 'CD-R   CDU926S  '
Revision       : '1.1f'
Device seems to be: Sony CDU-924S.
Using driver for Sony CDU-924 (sony_cdu924).
Driver flags   : SWABAUDIO

Once I put a CD-R into the drive, the failures start.  I've tried several
new, straight-out-of-the-box CDs and all of them fail precisely the same

For completeness, I also tried putting a regular CD into the drive to see
what would happen.  As it turns out, it works fine.  That tells me the 
controller and basic drive electronics are working.  Since the failure
is consistently in SCB 0x25 (read capacity), it seems to me that a really
bad, brute force way to solve the problem would be to simply dummy up
a new read capacity function that pretends to read the CD and fills the
structure with reasonable data (anyone know how many 1024 byte blocks
there are on a blank CD?).  I tried it - it doesn't help.  There is a
different 0x25 out there somewhere.

I've tried turning on the debug output and even tried '-force' to see
if it would write to the drive.   

It would probably help my position to find out what ASC 0x89 is.  All 
I've been able to find so far is that it's vendor unique, and I just
haven't figured out yet how to find it.