Subject: Simple fix for 1.5.x/i386, trouble elsewhere (was: an driver trouble)
To: None <,>
From: Feico Dillema <>
List: current-users
Date: 03/02/2001 00:44:44
On Thu, Mar 01, 2001 at 12:49:03PM +0100, Feico Dillema wrote:
> On Wed, Feb 28, 2001 at 06:12:06PM +0100, Feico Dillema wrote:
> an_ltv_status datastructure in anreg.h. I.e. change line 503 (on
> NetBSD-1.5.x, but similar on -current):
> »·······u_int16_t»······»·······an_spare[4];

> This makes the ifconfig up succeed on 1.5.x. I haven't tested
> actually letting it talk to anything, but it looks ok sofar.
Tested it, and it makes either type of card work for me on
NetBSD-1.5.1 branch. Could you apply this trivial fix to the branch or
should I send-pr it still?

> However, when I tried a -current kernel (1.5S) I run into a new
> problem. I get the following error messages:
> ``failed to enable MAC''

> These appear on -current with either type card I have. Also the one
> that worked fine with a kernel -current as of approx. Feb-14. I looked
> at cvsweb for changes that might be the cause, but I cannot see any
> directly related files that have changed in the past few weeks. 
> In case that it's machine-specific; this happens on a thinkpad 770,
> with cardbus compiled in the kernel.
I doubt this is an an-driver issue as I cannot see any relevænt
changes there in the past few weeks. I think this is beyond my
expertise to dig into any further and I'm happy with it running on
1.5, but I'll be more than happy to test possible fixes send to me.
Anybody else having similar problems? Either with other PCMCIA or
cardbus cards? Should I send-pr this, even though I really do not have
much more to say about it?

Finally, I'm trying to get the an card to work on 1.5.1/alpha for
my Multia. The an-driver itself seems ok sofar, but PCMCIA interrupts
still do not work properly; changing IST_EDGE into IST_LEVEL in the
pcic-ic code helped. It got rid of the stray interrupts. With this
in my kernel config:

pcic*   at      isa? port 0x3e0 iomem 0xd0000 iosiz 0x4000 flags 1

both the an card and ep PCMCIA cards configure properly and get
irq 14 assigned at ifconfig up. I manage to send out 4 ICMP request
packets before a `an: device timeout', but that's all sofar; no
further packets get out, nor any ever get it. pinging over the ep
interface doesn't get me anything either.

I'll play with interrupt settings (and cvsweb) a bit more, and see if
I can get better results. But, of course, suggestions from
better-informed people are always welcome :).