Subject: Re: an driver trouble
To: None <current-users@netbsd.org>
From: Feico Dillema <feico@pasta.cs.uit.no>
List: current-users
Date: 03/01/2001 12:49:03
On Wed, Feb 28, 2001 at 06:12:06PM +0100, Feico Dillema wrote:
> The AIR-LCM342 card (bought at the last IETF meeting) works just fine
> (no WEP). The other one (AIR-PCM342) configures just fine, but gives
> me at `ifconfig up':
> 
> an0: record length mismatch -- expected 134, got 136
> an0 detached

This seems to be fixed by adding 2 more spare bytes to the
an_ltv_status datastructure in anreg.h. I.e. change line 503 (on
NetBSD-1.5.x, but similar on -current):

u_int16_tan_spare[2];

into:

u_int16_tan_spare[4];

This makes the ifconfig up succeed on 1.5.x. I haven't tested
actually letting it talk to anything, but it looks ok sofar.
I'll let you know whether the card is fully working now when I get
home again (tomorrow).

However, when I tried a -current kernel (1.5S) I run into a new
problem. I get the following error messages:

``failed to enable MAC''

These appear on -current with either type card I have. Also the one
that worked fine with a kernel -current as of approx. Feb-14. I looked
at cvsweb for changes that might be the cause, but I cannot see any
directly related files that have changed in the past few weeks. 

In case that it's machine-specific; this happens on a thinkpad 770,
with cardbus compiled in the kernel.

Feico.