Subject: Re: Error compiling current kernel
To: None <>
From: Izumi Tsutsui <>
List: current-users
Date: 02/13/2001 20:50:44
In <v04220800b6ae47f9c9cb@[]> wrote:

> >It seems your gas is too old. What version are you running?

> it say : GNU assembler version 1.92.3, NetBSD $Revision: 1.3 $

"%" register prefix feature for m68k was added in
gnu/usr.bin/gas/config/tc-m68k.h rev 1.5.

> I tried to compile a new version but I got an another error :
> Unknown modifier '@'
> make: don't know how to make Stop

Maybe you have to build usr.bin/make and gnu/usr.bin/texinfo first.

> My system seem to be really out of date.
> Would it be possible to upgrade to 1.5 without redownloading everything.

Hmm, I guess your system is mostly 1.4-release.
I have not tried such upgrading path, but
some other tools (rpcgen, yacc etc) also have to be updated.
/usr/src/UPDATING may help you.
(It was create after 1.5-release was branched, though.)
Izumi Tsutsui