Subject: Re: UBC breaks my IDE disk!?!
To: Chuck Silvers <>
From: Urban Boquist <>
List: current-users
Date: 02/07/2001 12:02:59
>>>>> Chuck Silvers writes:

Chuck> hi urban, yea, this certainly sounds like a UBC problem given
Chuck> the date when it started happening.

Hi Chuck and Manuel, and thanks for your replies. I've done more
testing now and I think I can say for sure:

* UBC is probably not the cause of the problem, it just made it worse

* my hardware is ok, NetBSD-1.5 runs rock solid

* different NetBSD-currents the last few months all breaks in
  mysterious ways

In my previous mail I said that a November 25 kernel (just before UBC)
worked fine. That was wrong. It seemed to handle high IO loads fine
for several hours (copying files and packing/unpacking with tar), but
when I tried some large C++ compilations in parallell I soon got a
couple of uvm_fault panics.

I then reverted to a November 13 kernel, which seemed to handle IO
using tar/cp ok, and also the C++ compilations, but when I tried to
build a kernel I got lots of spurious seg-faults from the compiler.

At that point I thought there was something severely wrong with my
hardware, so I decided to install NetBSD-1.5. And now, two days later
with almost constant compilations and other things going on I haven't
seen a single problem... knock on wood... ;-)

I'll try to see if I can pinpoint exactly when -current started
failing. I will also try the patch to i386/machdep.c sent out
yesterday (thanks for the hint Manuel!). But I'm afraid this will take
some time, I desperately need this machine stable for my daily work.


        -- Urban