Subject: Re: assert13 and strlcat not found
To: Tom Javen <>
From: Chris Gilbert <>
List: current-users
Date: 02/07/2001 09:45:31
On Wednesday 07 February 2001  6:56 am, Tom Javen wrote:
> Geoff Wing wrote:
> > Ruibiao Qiu <> typed:
> > :Okay. I installed 1.5 binaries, update *.mk files and make, but
> > :when I tried "make build" under src, I still got error saying
> > :"___assert13" unresolved when building lib/libasn1.  I tried to
> > :build libc, but there was error with lint (illeagle option -X).
> > :What should I do to fix this?  Thanks.
> >
> > lint has only had -X for about 6 months.
> >
> > (do from a Bourne shell variant)
> > % cd src/lib/libc && MKLINT=no MKSHARE=no make dependall install
> > % cd ../../usr.bin/xlint && make dependall install
> >
> > Then try your "make build" again.  Don't remember what other
> > problems you'll run into - make sure you keep copies of /usr/libexec/ld*
> > just in case.
> mklocale has to be built and installed also .

The sequence is something like:
install new make (potentially need to do a make cleandir here, if using make 
obj later)
install new share/mk
make obj (if you build this way)
install lint
install lib/libc
install mklocale
install yacc (depends how recent the source is but yacc has been altered 
you may want to now do a make cleandir here so that everything is rebuilt.

then try a make build

That covers most of what I remember doing to build current here.