Subject: Re: assert13 and strlcat not found
To: Todd Vierling <>
From: Ruibiao Qiu <>
List: current-users
Date: 02/06/2001 21:21:07
On Tue, 6 Feb 2001, Todd Vierling wrote:

>On Tue, 6 Feb 2001, Ruibiao Qiu wrote:
>: I followed the src/UPDATING instructions: built a kernel
>: (with OBJECT_FMT=A_OUT trick again), added OBJMACHINE and
>: MKOBJDIRS in /etc/mk.conf.  But, I am having problem with "make
>: build".  The error is "___assert13" and "___strlcat" unresolved
>: symbols.  What do I need to rebuild?  libc?  How?  Thanks.
>If you are trying to upgrade from this early of a system, you should start
>with real binaries from a 1.5 release and build from there.  We don't
>support upgrading entirely from source between 1.4 and 1.5.

Okay. I installed 1.5 binaries, update *.mk files and make, but
when I tried "make build" under src, I still got error saying
"___assert13" unresolved when building lib/libasn1.  I tried to
build libc, but there was error with lint (illeagle option -X).
What should I do to fix this?  Thanks.