Subject: Has anyone got an Iomega USB ZipCD-RW drive working on -current?
To: None <>
From: Duncan McEwan <duncan@MCS.VUW.AC.NZ>
List: current-users
Date: 01/30/2001 17:45:42
We've just got one of these drives.  I plugged it in to a NetBSD 1.5Q
system (i386) built from sources around 17th Jan.  It looks pretty good
to start with:

   umass0 at uhub0 port 1 configuration 1 interface 0
   umass0: Iomega USB Zip CD, rev 1.00/1.00, addr 2
   umass0: using SCSI over BBB-P
   scsibus0 at umass0: 2 targets, 1 luns per target
   scsibus0: waiting 2 seconds for devices to settle...
   cd1 at scsibus0 target 1 lun 0: <IOMEGA, ZIPCD 650 USB, I1.1> SCSI0
   5/cdrom removable

But when I try

   mount -r -t cd9660 /dev/cd1a /mnt/cd		# (or cd1d)

I get the following error

   mount_cd9660: /dev/cd1a on /mnt/cd: Invalid argument

Also, the following message gets syslogged

   cd1(umass0:1:0):  Check Condition on CDB: 0x08 00 00 10 01 00
       SENSE KEY:  Illegal Request
        ASC/ASCQ:  Invalid Command Operation Code

If I type "eject cd1" the expected thing happens!

Just for kicks, I also tried running cdrecord (vers 1.9, built from pkgsrc),
after symlinking /dev/su0-1-0 to /dev/cd1d:

  # cdrecord -v dev=0,1,0
  Cdrecord 1.9 (i386-unknown-netbsd1.5E) Copyright (C) 1995-2000 Jorg Schilling
  TOC Type: 1 = CD-ROM
  scsidev: '0,1,0'
  scsibus: 0 target: 1 lun: 0
  Using libscg version 'schily-0.1'
  atapi: 0
  Device type    : Removable CD-ROM
  Version        : 0
  Response Format: 1
  Vendor_info    : 'IOMEGA  '
  Identifikation : 'ZIPCD 650 USB   '
  Revision       : 'I1.1'
  Device seems to be: Generic CD-ROM.
  cdrecord: Sorry, no CD/DVD-Recorder or unsupported CD/DVD-Recorder found on
  this target.

And the following gets syslogged:

  umass0: Phase Error, residue = 0
  cd1(umass0:1:0): unknown error category 8 from host adapter code

If I run cdrecord with different "driver=" arguments I get the same error,
unless I use "driver=mmc_cdr" in which case I get

  cdrecord: WARNING: Trying to use other driver on known device.
  cdrecord: Cannot attach driver for CD/DVD-Recorder.

(I didn't try all the driver options listed by "driver=help" though).

Has anyone got this, or any other USB CD-RW drive to work?