Subject: Re: -current on Ultra 5+ - now it's major siop0 lossage
To: Manuel Bouyer <>
From: Jim Bernard <>
List: current-users
Date: 01/29/2001 08:56:24

On Mon, Jan 29, 2001 at 12:12:26PM +0100, Manuel Bouyer wrote:
> On Sat, Jan 27, 2001 at 01:51:23PM -0700, Jim Bernard wrote:
> >   I saw something similar on an i386 using siop a couple of weeks ago (this was
> > the first time I had tried the siop driver).  I ran the system with it for a
> > couple of days, and saw several instances of this problem in the logs.  One
> > time when it happened I was working at the console, and it froze, but did
> > eventually recover.  I haven't had time to investigate, so I just switched
> > back to the ncr driver.
> Could you try again with an up-to-date -current kernel (or with the patches
> I posted) ? The table overflow I fixed could explain this.

  Yes, I've been running a kernel with the table-overflow fix for almost 24
hours now, and haven't seen the problem occur yet.  The longest time I saw
without it prior to the fix was about 20 hours (though I only ran that kernel
for about 2 days, so I don't have very good statistics).  So, it looks like
you have probably fixed it, at least in my case (I gather Greg still has
some trouble, though).  I'll let you know if it does happen again.