Subject: dhcpd fix (was Re: dhcpd dies even with ddns-updates off)
To: None <>
From: Tracy J. Di Marco White <>
List: current-users
Date: 01/28/2001 15:41:21
}}I'm running dhcpd on i386, 1.5.1_ALPHA about three weeks old.  Yesterday
}}I installed a new machine, added it to /etc/dhcpd.conf, and then whenever
}}it tried to get an address, dhcpd would die, core dump, sig 11.  I removed
}}the new machine from /etc/dhcpd.conf, in case there was something odd with
}}that, but now no matter which machine that had been able to get addresses
}}before tries, dhcpd dies after DHCPDISCOVER & DHCPOFFER, as it's receiving

}I updated to 1.5.1_ALPHA of yesterday evening (Jan 27, 2001) and tried again.
}Now, if I restart it fast enough it will hand out the address:

I upgraded to dhcp 3.0b2pl16 and now dhcp works.  We had to add
ddns-update-style ad-hoc;
to the dhcpd.conf, but that not allowed in 3.0b2pl9 (which is in
1.5.1_ALPHA).  Seems a bit odd to have to add that when we have
ddns-updates off;
set, but at least it's working again.

I'll submit a pr, I don't know if anyone else has seen this problem,
but it is a serious problem to me.

Tracy J. Di Marco White
Project Vincent Systems Manager